Press "Enter" to skip to content

Protocolo DHCP – Configuração e funcionalidades

0

O que é DHCP? Como funciona e como configurar em switches Cisco

DHCP (Dynamic Host Control Protocol) permite que um switch configurado com uma interface de camada 3 funcione como servidor, para atribuir automaticamente endereços IPv4.

DHCP é um protocolo que oferece configuração de endereçamento IP para hosts na rede e está construído em um modelo de cliente/servidor, na qual o servidor mantém o gerenciamento centralizado de endereços IPs usados na rede.

Um cliente DHCP pode passar por seis estados de aquisição:

  • Inicializa: Quando um cliente inicializa pela primeira vez, ele difunde uma mensagem para todos os servidores DHCP da rede local a fim de adquirir as configurações de inicialização na rede. Para tanto ele manda uma mensagem DHCPDISCOVER.

O DHCP DISCOVER é enviado em um datagrama UDP da mesma forma que no BOOTP. Após o envio dessa mensagem, o cliente passa para o estado SELECIONA.

  • Seleciona: Neste estado, o cliente permanece aguardando a resposta dos servidores DHCP que receberam o DHCPDISCOVER. Aqueles servidores que estiverem configurados para responder enviam ao cliente uma mensagem DHCPOFFER. Nesta mensagem, estão embutidas as informações necessárias para a configuração do cliente juntamente com um endereço IP que o servidor lhe oferece como empréstimo. Após o recebimento de todas as mensagens enviadas pelos servidores, o cliente irá optar por uma e entrará em negociação de locação com o servidor ofertante. Para iniciar a negociação, o cliente envia a mensagem DHCPREQUEST. Neste momento, ele entra no estado SOLICITA.
  • Solicita: Aqui, o cliente aguarda uma resposta de confirmação do servidor DHCP que ele entrou em negociação. Essa confirmação é remetida através da mensagem DHCPACK. Com o recebimento da confirmação, o cliente passa a ter um endereço IP e utiliza-o, bem como todas as outras informações de configuração que foram enviadas pelo servidor e entra no estado LIMITE.
  • Limite: Este é o estado em que permanece o cliente durante a utilização do endereço IP até que atinja o período de renovação ou ele decida não mais utilizar o endereço locado. Para este último caso, onde o cliente não espera o término do prazo da locação, ele envia uma mensagem DHCPRELEASE para o servidor, a fim de provocar a liberação do endereço IP locado. Desta forma, o cliente não mais poderá enviar datagramas IP utilizando-se do endereço que possuía e passa para o estado INICIALIZA.
  • Renova: Ao receber um DHCPACK, o cliente adquire a informação do período de locação do endereço. De posse dessa informação, ele inicializa três temporizadores. Eles são utilizados para controlar os períodos de renovação, revinculação e do fim da locação. O servidor pode especificar o valor de cada temporizador. Não havendo essa especificação o cliente utiliza os valores padrões, que são de 50%, 85% e 100%, respectivamente.

Quando o temporizador ultrapassa o valor da renovação, o cliente tentará renovar a locação. Para isso, ele faz uso novamente do DHCREQUEST ao servidor. Assim, ele passa para o estado RENOVA e aguarda a resposta. Na mensagem, segue embutido o endereço IP atual do cliente e uma solicitação de extensão da locação do mesmo.

O servidor poderá responder autorizando a renovação da locação que necessariamente não possuirá o período anteriormente destinado, ou poderá responder de forma negativa. No primeiro caso, o servidor envia um DHCPACK ao cliente. O recebimento dessa mensagem faz com que o cliente retorne ao estado limite. No segundo caso, o servidor envia um DHCPNACK, que faz com que o cliente interrompa o uso do endereço IP e passe para o estado INICIALIZA.

SWITCH CISCO – CONFIGURAÇÃO DHCP

 Os seguintes passos descrevem a configuração de um roteador executando IOS como servidor DHCP.

Criar um pool de endereços que serão associadas aos clientes:

Switch(config)# ip dhcp pool name

Determinar o endereçamento de rede e mascara para o pool.

Switch(config-dhcp)# network network/mask

Configurar o período que o cliente poderá dispor desse endereço. Esse período de aluguel normalmente são 3 dias; em versos de IOS é de 1 dia, mas pode configurar em horas, minutos e segundos.

Switch(config-dhcp)# lease [infinite | days | hours minutes]

Identificar o servidor DNS

Switch(config-dhcp)# dns-server address

 Identificar a porta de enlace (gateway)

Switch(config-dhcp)# default-roteadorip-address

 Excluir se necessários os endereços que por segurança ou para evitar conflitos não necessitam que sejam atribuídos no DHCP

Switch(config-)# ip dhcp excluded-address start-ip end-ip

 Os endereços IPs são sempre atribuídos na mesma interface que tem o IP dentro do pool definido. A seguinte sintaxe mostra um exemplo de configuração:

Switch(config)# interface fastethernet 0/0
Switch(config-if)# ip address 192.168.1.1 255.255.255.0
Switch(config)# ip dhcp pool 1
Switch(config-dhcp)# network 192.168.1.0
Switch(config-dhcp)# defalt-network 192.168.1.1
Switch(config-lease)# lease 3
Switch(config-dhcp)# dns-server 192.168.1.1

Alguns dispositivos IOS recebem o endereçamento IP em algumas interfaces e atribuem endereços IP em outras. Para esses casos DHCP pode impor ar as opções e parâmetros de uma interface a outra. O seguinte comando executa essa ação:

Switch(config-dhcp)# import all

Esse comando é muito útil quando devemos configurar o DHCP em escritórios remotos. O roteador uma vez localizado em seu site pode determinar o DNS e as opções locais.

A seguinte tabela descreve uma serie de comandos opcionais:

Comando Descrição
 

Service dhcp

 

Habilita o servidor DHCP que por padrão está habilitado.
 

Ip dhcp database

 

Configura um agente de base de dados
 

No ip dhcp conflict logging

 

Desabiita o login de conflitos
 

Ip dhcp exluded-address start-ip end-ip

 

Define os endereços que serão excluídos do pool
 

Domain-name domain

DNS atribuido por padrão

  

SWITCH CISCO – CONFIGURAÇÃO DHCP RELAY

protocolo-dhcp-configuracao-e-funcionalidades

Normalmente os roteadores não retransmitem tráfego broadcast. Em alguns casos uma exceção a essa regra poderia ser muito útil.

Um servidor DHCP centralizado que ofereça um endereçamento a todas as redes remotas seria mais fácil de administrar e resolver possíveis conflitos. Todos os roteadores nesse caso deveria deixar passar todo o trafego broadcast originado pelas transações DHCP.

Um roteador configurado para deixar passar os DHCP request é chamado de DHCP relay. Quando é configurado, o roteador permitirá o reenvio de broadcast enviado pela porta UDO determinada até uma localização remota. O DHCP Relay reenvia os request e configura a porta de enlace no roteador local.

Switch(config-if)# ip helper-address address

 Quando essa função é configurada, suportar 8 portas UDP por padrão, qualquer broadcast recebido nessas portas são reenviados para o endereço IP configurado no comando helper-address.

 As portas UDP são as seguintes:

  • NTP (UDP 37)
  • TACACS (UDP 49)
  • DNS (UDP 53)
  • DHCP (UDP 67 e 68)
  • TFTP (UDP 69)
  • NetBIOS name service (UDP 137)
  • NetBIOS datagram service (UDP 138)

Adicionalmente poderíamos configurar mais portas com o comando:

Switch(config)# ip forward-protocol udp port

O seguinte exemplo mostra a sintaxe da configuração de uma porta UDP adicional.

Switch(config)# interface fastethernet 0/0
Switch(config-if)# ip address 192.168.1.1 255.255.255.0
Switch(config-if)# ip forward-protocol udp 4400
Switch(config-if)# no ip forward-protocol udp 69

O comando ip dhcp relay information option utilizado com o DHCP relay habilita o sistema para inserir a opção 82 (agente DHCP relay information option) em mensagens Bootrequest que são enviados ao servidor DHCP. O servidor pode utilizar essa informação para atribuir a sub-rede correta.

Para configurar uma interface como cliente dhcp, utilizamos a seguinte configuração:

Switch(config)# interface fastethernet 0/0
Switch(config-if)# ip address dhcp

 

Lembrando que um switch ou roteador podem ser cliente e server ao mesmo tempo em diferentes interfaces.

 

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

%d blogueiros gostam disto: