Press "Enter" to skip to content

Comparação de Configuração – Switch Cisco e Huawei

0

Comparação de Configuração – Switch Cisco e Huawei – Estrutura de configuração e comparação dos comandos Cisco vs Huawei mais utilizado entre os fabricantes.

Estrutura CLI

  • Cisco
    • Modo de usuário,  “>”  ex. Cisco>
    • Modo Privilegiado, “#”, ex. Cisco#
    • Modo de Configuração, “#” , ex. Cisco(config)#
    • Outros modos de configuração,  “#”, ex. Cisco(config-XX)#
  • Huawei
    • Modo de usuário, “< >”, ex. <Huawei>
    • Modo Privilegiado, “[ ]”, ex. [Huawei]
    • Outros modos de configuração,  “[ ]”, ex. [Huawei-XX]

Você pode ver que a Huawei nunca tem o modo de configuração único como a Cisco, a visão do sistema do Huawei é equivalente ao modo privilegiado mais o modo de configuração da Cisco.

Comparação de Configuração - Switch Cisco e Huawei

Comparação dos principais comandos

A maioria das palavras-chave do comando Huawei tem o contraste fixo com a Cisco, saber sobre isso irá ajudá-lo a aprender o comando Huawei rapidamente se você tiver uma boa habilidade na Cisco.

  • Cisco <–> Huawei
show <- -> display
no <- -> undo
exit <- -> quit
clear <- -> reset
debug <- -> debugging
neighbor <- -> peer
detail <- -> verbose
delete <- -> delete
match <- ->if-match

Comparação de Comandos Básicos Cisco vs Huawei

Configurar o nome do host
Cisco (config) # hostname <hostname>
[Huawei] sysname <sysname>
Exibir informações sobre a versão
Cisco# show version
[huawei] display version
Exibir informações sobre a configuração
Cisco# show running-configuration
[Huawei] display current-configuration
Exibir informações a interface
Cisco # show interface [interface-type [interface-number]]
[huawei] display interface [ interface-type [ interface-number ] ]

O comando Huawei “display this” é um comando conveniente para mostrar a configuração na visão atual, você pode utilizá-lo realizando a configuração de interfaces e protocolos.

 

Dados da Console Huawei

A Huawei utiliza o mesmo padrão utilizada pela console da Cisco.

Bit per second (Baud rate): 9600
Data Bits: 8
Parity Check: None
Stop Bits: 1
Flow Control: None

Configuração de usuário local – Huawei vs Cisco

  • Huawei
Entrar em modo de configuração
<Quidway> system-view
Entrar no modo de configuração do AAA
[Quidway] aaa
Criar um usuário local e configurar senha
[Quidway-aaa] local-user Huawei password simple 123456
Especificar o nivel de usuário
[Quidway-aaa] local-user Huawei level 3
Especificar o tipo de acesso
[Quidway-aaa] local-user Huawei service-type telnet
  • Cisco
Entrar em modo de configuração
Cisco# configure terminal
Criar um usuário local e configurar senha
Cisco(config)# username Huawei password 123456
Especificar o nivel de usuário
Cisco(config)# username Huawei privilege 3

Os  privilegios são divididos em 4 níveis:

Privilege Permissão Descrição
0 Visitante Comandos neste nível são comandos de diagnóstico, tais como ping e tracert e comandos que são usados para acessar um dispositivo remoto, como clientes Telnet.
1 Monitoração Comandos a este nível são os comandos de manutenção do sistema, tais como comandos de exibição. Alguns comandos de exibição não são a este nível. Por exemplo, display current-configuration display saved- configuration no nível 3.
2 Configuração Comandos a este nível são os comandos de configuração de serviços
3-15 Gerenciamento Comandos neste nível são comandos de operações básicas do sistema para o suporte, incluindo sistema de arquivos FTP, TFTP, administração de usuário, comandos a nível de configuração e debugging.

Configuração SSH

  • Huawei
<Quidway> system-view
[Quidway] aaa
[Quidway-aaa] local-user Huawei password simple 123456
[Quidway-aaa] local-user Huawei service-type ssh
[Quidway-aaa] local-user Huawei level 3
[Quidway-aaa] quit
Gerar a chave RSA
[Quidway] rsa local-key-pair create
Habilitar o Stelnet
[Quidway] stelnet server enable
[Quidway] ssh user Huawei authentication-type password
Configurar o VTY para SSH
[Quidway] user-interface vty  0 4
[Quidway-ui-vty0-4] authentication-mode aaa
[Quidway-ui-vty0-4] protocol inbound ssh
  • Cisco
Cisco# configure terminal
Cisco(config)# username Huawei password 123456
Cisco(config)# username Huawei privilege 3
Gerar a chave RSA
Cisco(config)# ip domain-name test
Cisco(config)# crypto key generate rsa
Configurar o VTY para SSH
Cisco(config)# line 0 4
Cisco(config-line)# login local
Cisco(config-line)# transport input ssh

Configuração NTP –  Huawei vs Cisco

Huawei

Switch A (Master)
<Quidway_A> system-view
[Quidway_A] ntp-service refclock-master  2
Switch B (Cliente)
<Quidway_B> system-view
[Quidway_B] ntp-service unicast-server 172.16.1.1
  • Cisco
Switch A (Master)
Cisco_A# configure terminal
Cisco_A(config)# ntp master 2
Switch B (Cliente)
Cisco_B# configure terminal
Cisco_B(config)# ntp server 172.16.1.1

criação de VLAN, agregação de portas LACP entre interface CLI Cisco vs Huawei.

Configuração de Interface e Porta

  • Huawei
    • Entrar em modo de configuração
      • <Quidway> system-view
    • Configurar a porta como auto negociação (valor habilitado por padrão)
      • [Quidway] interface GigabitEthernet1/0/1
      • [Quidway-GigabitEthernet1/0/1] negotiation auto
    • Configurar a velocidade da interface
      • [Quidway-GigabitEthernet1/0/1] auto speed { 10 | 100 | 1000 }*
    • Configurar a interface em modo auto duplex
      • [Quidway-GigabitEthernet1/0/1] auto duplex { full | half } *
  • Cisco
    • Entrar em modo de configuração
      • Cisco# configure terminal
    • Configurar a porta como auto negociação
      • Cisco(config)# interface Gigabitethernet1/0/1
      • Cisco(config-if)# no speed
    • Configurar a velocidade da interface
      • Cisco(config-if)# speed auto { 10 | 100 | 1000 }*
    • Configurar a interface em modo auto duplex
      • Cisco(config-if)# duplex auto

Forçar a velocidade e o modo duplex

  • Huawei
    • Entrar em modo de configuração
      • <Quidway> system-view
    • Desabilitar a auto negociação da interface
      • [Quidway] interface GigabitEthernet1/0/1
      • [Quidway-GigabitEthernet1/0/1] undo negotiation auto
    • Configurar a velocidade da interface
      • [Quidway-GigabitEthernet1/0/1] speed { 10 | 100 | 1000 }*
    • Configurar a interface em modo full ou half duplex
      • [Quidway-GigabitEthernet1/0/1] duplex { full | half } *
  • Cisco
    • Entrar em modo de configuração
      • Cisco# configure terminal
    • Desabilitar a auto negociação da interface
      • Cisco(config)# interface Gigabitethernet1/0/1
      • Cisco(config-if)# speed nonegotiate
    • Configurar a velocidade da interface
      • Cisco(config-if)# speed { 10 | 100 | 1000 }*
    • Configurar a interface em modo duplex full ou half
      • Cisco(config-if)# duplex { full | half }

Configurar Interface Jumbo frame – CLI Cisco vs Huawei

  • Huawei
    • Entrar em modo de configuração
      • <Quidway> system-view
    • Configurar o tamanho máximo do frame enviado pela interface
      • [Quidway] interface GigabitEthernet1/0/1
      • [Quidway-GigabitEthernet1/0/1] jumbo enable value
  • Cisco
    • Entrar em modo de configuração
      • Cisco# configure terminal
    • Configurar o tamanho máximo do frame enviado pela interface
      • Cisco(config)# system mtu  jumbo value

Configurar Power over Ethernet  (POE) – Cisco vs Huawei

  • Huwei

Ativar a função POE na interface, por padrão, a função POE é habilitada automaticamente na interface

<Quidway> system-view
[Quidway] interface Ethernet0/0/1
[Quidway-Ethernet0/0/1] poe enable
Opctional – Configurar a energia máxima enviada pela porta
[Quidway-Ethernet0/0/1] poe max-power power_values
[Quidway-Ethernet0/0/1] quit
Opcional – Configure o PoE de forma manual nas interfaces
[Quidway] poe power-management manual
[Quidway] poe power-on interface Ethernet0/0/1
  • Cisco
Ativar a função POE na interface, por padrão, a função POE é habilitada automaticamente na interface

Cisco# configure terminal
Cisco(config)# interface FastEthernet0/0/1
Cisco(config-if)# power inline auto

Opctional – Configurar a energia máxima enviada pela porta

Cisco(config-if)# power inline [auto | static] max power_values
Opcional – Configure o PoE de forma manual nas interfaces
Cisco(config-if)# power inline static

Configurar agregação de portas LACP

  • Huawei
Entrar em modo de configuração

<Quidway> system-view

Habilitar o channel group

[Quidway] interface Eth-Trunk 1

Configurar o metodo de balanceamento do channel group

[Quidway-Eth-Trunk1] load-balance method

Especificar o modo LACP

[Quidway-Eth-Trunk1] mode lacp-static

[Quidway-Eth-Trunk1] bpdu enable

[Quidway-Eth-Trunk1] quit

Especificar a interface ao channel group criado

[Quidway] interface GigabitEthernet1/0/1

[Quidway-GigabitEthernet1/0/1] eth-trunk 1

Especificar a prioridade LACP

[Quidway-GigabitEthernet1/0/1] lacp port-priority priority-value

[Quidway-GigabitEthernet1/0/1] quit

Configurar a prioridade LACP do sistema

[Quidway] lacp port-priority priority-value
  • Cisco
Entrar em modo de configuração

Cisco# configure terminal

Habilitar channel group

Cisco(config)# interface port-channel Cisco(config-if)# switchport
Cisco(config-if)# exit

Configurar o metodo de balanceamento do channel group

Cisco(config)# port-channel load-balance method

Especificar o modo LACP e a interface associada.

Cisco(config)# interface GigabitEthernet1/0/1
Cisco(config-if)# channel-group 1 mode active
Cisco(config-if)# channel-protocol lacp

Especificar a prioridade LACP
Cisco(config-if)# lacp port-priority priority-value
Cisco(config-if)# exit

Configurar a prioridade LACP do sistema

Cisco(config)# lacp system-priority priority-value

Configuração de Porta e VLAN

  • Huawei
Você pode criar uma ou várias VLANs de uma só vez
[Quidway] vlan 2
[Quidway] vlan bacth 2 to 10
Configure a VLAN 2 como acesso na portaGigabitEthernet1/0/1
[Quidway] interface GigabitEthernet1/0/1
[Quidway-GigabitEthernet1/0/1] port link-type access
[Quidway-GigabitEthernet1/0/1] port default vlan 2
Configure a porta G1/0/1 como trunk
[Quidway] interface GigabitEthernet1/0/1
[Quidway-GigabitEthernet1/0/1] port link-type trunk
[Quidway-GigabitEthernet1/0/1] port trunk allow vlan 2 to 10
  • Cisco
Você pode criar uma ou várias VLANs de uma só vez

Cisco(config)# vlan 2
Cisco(config)# vlan 2-10

Configure a VLAN 2 como acesso na porta GigabitEthernet1/0/1

Cisco(config)# interface GigabitEthernet1/0/1
Cisco(config-if)# switchport mode access
Cisco(config-if)# switchport access vlan 2

Configure a porta G1/0/1 como trunk

Cisco(config)# interface GigabitEthernet1/0/1
Cisco(config-if)# switchport trunk encapsulation dot1q
Cisco(config-if)# switchport mode trunk
Cisco(config-if)# switchport trunk allowed vlan 2-10

CONFIGURAR VLAN DE VOZ COM LLDP-MED

Passo 1 – Configurar o Voice-VLAN

    • Huawei
      • Criar a VLAN no sistema
        • <Quidway> system-view
        • [Quidway] vlan 8
          • [Quidway-vlan-8] quit
      • Configura o OUI na Voice VLAN
        • [Quidway] voice-vlan mac-address mac-address mask oui-mask [description text]
      • Habilita a voice VLAN e confia no COS da interface conectada ao telefone IP
        • [Quidway] interface Ethernet1/0/1
          • [Quidway-Ethernet1/0/1] voice-vlan 8 enable
          • [Quidway-Ethernet1/0/1] trust 8021p
          • [Quidway-Ethernet1/0/1] quit
  • Passo 2 – Configurar o LLDP-MED
    • Habilite globalmente o LLDP
      • [Quidway] lldp enable
    • Habilite o BPDU na interface conectada ao telefone IP
      • [Quidway] interface Ethernet1/0/1
      • [Quidway-Ethernet1/0/1] bpdu enable
  • Cisco
    • Criar a VLAN no sistema
      • Cisco# configure terminal
        • Cisco(config)# vlan 8
          • Cisco(config-vlan)# exit
    • Habilite a QoS no switch
      • Cisco(config)# mls qos
    • Habilita a voice VLAN e confia no COS da interface conectada ao telefone IP
      • Cisco(config)# interface FastEthernet1/0/1
        • Cisco(config-if)# switchport voice vlan 8
        • Cisco(config-if)# mls qos trust cos
        • Cisco(config-if)# exit
  • Passo 2 – Configurar o LLDP-MED
    • Habilite globalmente o LLDP
      • Cisco(config)# lldp run
    • Habilite o BPDU na interface conectada ao telefone IP
      • Cisco(config)# interface FastEthernet1/0/1
      • Cisco(config-if)# lldp receive
      • Cisco(config-if)# lldp transmit
      • Cisco(config-if)# lldp med-tlv-select network-policy

Faremos uma breve abordagem do protocolo Huawei VBST  (similar ao PVST da Cisco).

Configuração RSTP Básico

  • Huawei
    • Configurar em todos os switches
      • Configure o spanning tree em modo RSTP
        • <Quidway> system-view
        • [Quidway] stp mode rst
        • [Quidway] stp enable
    • Configure o Switch A como root
      • [Quidway_A] stp root primary
      • [Quidway_A] stp priority 0
  • Cisco
    • Configurar em todos os switches
      • Configure o spanning tree em modo RSTP-Pvst
        • Cisco# configure terminal
        • Cisco(config)# spanning-tree mode rapid-pvst
      • Configure o spanning-tree link-type como point-to-point
        • Cisco(config)# interface GigabitEthernet1/0/1
          • Cisco(config-if)# spanning-tree link-type point-to-point
          • Cisco(config-if)# exit
        • Cisco(config)# interface GigabitEthernet1/0/2
          • Cisco(config-if)# spanning-tree link-type point-to-point
    • Configure Switch A como root
      • Cisco_A(config)# spanning-tree vlan vlan-id root primary
      • Cisco_A(config)# spanning-tree vlan vlan-id priority 0

Configuração Protocolo MSTP – Multiple Spanning Tree

  • Huawei

    • Todos os switches
      • Configure o spanning tree em modo MSTP
        • <Quidway> system-view
        • [Quidway] stp mode mstp
        • [Quidway] stp enable
      • Configure a região no MST
        • [Quidway] stp region-configuration
          • [Quidway–mst-region] region-name Huawei
          • [Quidway–mst-region] instance 1 vlan 1 to 10
          • [Quidway–mst-region] instance 2 vlan 11 to 20
          • [Quidway–mst-region] active region-configuration
      • Switch A (root da instance 1)
        • Configure o Switch A como root da instancia 1
          • Quidway_A] stp instance 1 root primary ou
          • [Quidway_A] stp instance 1 priority 0
      • Switch C (root da instance 2)
        • Configure o Switch C como root da instancia 2
          • [Quidway_C] stp instance 2 root primary
          • [Quidway_C] stp instance 2 priority 0
  • Cisco

    • Todos os switches
      • Configure o spanning tree em modo MSTP
        • Cisco# configure terminal
        • Cisco(config)# spanning-tree mode mst
      • Configure a região no MST
        • Cisco(config)#spanning-tree mst configuration
        • Cisco(config-mst)#name Huawei
        • Cisco(config-mst)#instance 1 vlan 1-10
        • Cisco(config-mst)#instance 2 vlan 11-20
    • Switch A (root da instance 1)
      • Configure o Switch A como root da instancia 1
        • Cisco_A(config)# spanning-tree mst 1 root primary ou
        • Cisco_A(config)# spanning-tree mst 1 priority 0
    • Switch C (root da instance 2)
      • Configure o Switch C como root da instancia 2
        • Cisco_C(config)# spanning-tree mst 2 root primary
        • Cisco_C(config)# spanning-tree mst 2 priority 0

Configuração STP – Spanning Tree

Principais Comandos de configuração do protocolo Spanning Tree:

Cisco Huawei
spanning-tree portfast stp edged-port enable
spanning-tree bpdufilter enable stp bpdu-filter enable
spanning-tree portfast bpduguard default stp bpdu-protection
spanning-tree mode mst stp mode mstp
spanning-tree link-type point-to-point stp point-to-point force-true
spanning-tree guard root stp root-protection
spanning-tree bpduguard enable stp edged-port enable + bpdu enable
spanning-tree bpdufilter stp bpdu-filter enable
spanning-tree mode mst stp mode mstp
spanning-tree mode pvst stp mode stp
spanning-tree mode rapid-pvst stp mode rstp
spanning-tree mst configuration stp region-configuration

Cisco PVST vs Huawei VBST

VBST (VLAN-based Spanning Tree) é um protocolo spanning tree proprietário Huawei equivalente e compatível com PVST da Cisco, utiliza as arvores e prioridades por VLANs de forma independente.

Exemplo de Configuração:

  • Configuração do switch A

    • sysname SwitchA
      • vlan batch 10 20 30
      • stp mode vbst
      • stp vlan 1 disable
      • stp vlan 30 root secondary
      • stp vlan 10 20 root primary
      • interface GigabitEthernet0/0/1
        •  port link-type trunk
        •  undo port trunk allow-pass vlan 1
        •  port trunk allow-pass vlan 10 20 30
      • interface GigabitEthernet0/0/2
        •  port link-type trunk
        •  undo port trunk allow-pass vlan 1
        •  port trunk allow-pass vlan 20 30
      • interface GigabitEthernet0/0/3
        •  port link-type trunk
        •  undo port trunk allow-pass vlan 1
        •  port trunk allow-pass vlan 10 20
  • Configuração do switch B

    • sysname SwitchB
    • vlan batch 10 20 30
    • stp mode vbst
    • stp vlan 1 disable
    • stp vlan 10 20 root secondary
    • stp vlan 30 root primary
    • interface GigabitEthernet0/0/1
      •  port link-type trunk
      •  undo port trunk allow-pass vlan 1
      •  port trunk allow-pass vlan 10 20 30
    • interface GigabitEthernet0/0/2
      •  port link-type trunk
      •  undo port trunk allow-pass vlan 1
      •  port trunk allow-pass vlan 10 20
    • interface GigabitEthernet0/0/3
      •  port link-type trunk
      •  undo port trunk allow-pass vlan 1
      •  port trunk allow-pass vlan 20 30
  • Configuração do Switch C

    • sysname SwitchC
    • vlan batch 10 20
    • stp mode vbst
    • stp vlan 1 disable
    • interface GigabitEthernet0/0/2
      •  port link-type trunk
      •  undo port trunk allow-pass vlan 1
      •  port trunk allow-pass vlan 10 20
      •  stp vlan 10 20 cost 2000000
    • interface GigabitEthernet0/0/3
      •  port link-type trunk
      •  undo port trunk allow-pass vlan 1
      •  port trunk allow-pass vlan 10 20
    • interface GigabitEthernet0/0/4
      •  port link-type access
      •  port default vlan 10
      •  stp edged-port enable
    • interface GigabitEthernet0/0/5
      •  port link-type access
      •  port default vlan 20
      •  stp edged-port enable
  • Configuração do switch D

sysname SwitchD
vlan batch 20 30
stp mode vbst
stp vlan 1 disable
interface GigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 20 30
 stp vlan 20 30 cost 2000000
interface GigabitEthernet0/0/3
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 20 30
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 20
 stp edged-port enable
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 30
 stp edged-port enable
 

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

%d blogueiros gostam disto: